Header Overview

 

The most frequently asked questions and answers regarding AscTec onboard computer systems. If your question is not answered here feel free to contact our support. For that, please take a look at the end of this page.


All processor boards

Q: How can I automatically start a program without mouse and keyboard?

A: The simplest way to start a program at system startup is to add it in

before the finale

Mostly you want to start programs in the context of a special user:

Explanations:

switch user
run command
run in context of target user
put command in background to continue boot process

Q: How can I use the AscTec Atomboard or Mastermind without a monitor attached?

A1: VNC/X11

A2: ssh

A3: serial console
E.g. with Putty (http://www.putty.org)

A4: Remotedesktop (http://www.xrdp.org)

Q: Why is one serial port (UART /dev/ttyS1 or /dev/ttyUSB1) not working?

A1: The preinstalled operating system starts a serial console (getty) on /dev/ttyS1 (Mastermind) or /dev/ttyUSB1 (Atomboard).
If you want to use this port for something else, stop and disable the service and this function by removing the startup script:

Mastermind:
Atomboard:

Since Ubuntu 12.04 the baudrate has changed to 9600 bps.

Q: How can I enable/disable auto start of GUI?

Please mind that it is not a good idea to run the X-server (GUI) when you don't need it: imagine an opengl screensaver draining your battery empty or the power manager putting the system to sleep in mid-air.

A1: Disable display manager auto start:

A2: Enable display manager autostart:

Q: The serial communication between my AscTec Atomboard/Mastermind and the AscTec AutoPilot is not working?

A1: If your Atomboard/Mastermind is powered by a different power supply than the AscTec AutoPilot, the serial communication can get disturbed.

E.g. if you have connected the Atomboard/Mastermind to an external power supply and the AscTec AutoPilot is powered by the standard battery, the serial connection might not work. It is okay to use an external power supply which powers both, the AscTec AutoPilot and the AscTec Atomboard/Mastermind.

A2: Make sure to use the correct cable on the correct serial port! Use the Atomboard -> AP/PEL Connection cable which comes with every Atomboard.

A3: Please note, that the AscTec Atomboard uses dev/ttyUSB and the AscTec Mastermind uses dev/ttyS as serial port names. Make sure these are not mixed up in preinstalled software like the ROS drivers or the ACI. A fast and easy fix would be e.g. a symbol link on the device via


AscTec Atomboard

Q: There are drop outs and lags in the wifi connection - what can I do?

A1: Use a free 5GHz channel (RC and XBee are on 2.4GHz)

A2: Try disabling the power management on the adapter:

If this helps you can make this change permanent by running the following command:

A3: Install wicd and uninstall network-mananger.(Sounds like voodoo but is reported as a working solution.)

Q: Why can't I connect to my wireless network? Why is it not visible when I run "sudo iwlist wlan0 scan"?

A: In rare occaissons it may happen that your access point has automatically selected a frequency the Atomboard's Wifi module is not able to use. This is due to the legal situation of some frequencies in certain countries. There are some limitations on the 2.4GHz Channels 12-14, check if your AP is running on one of these frequencies. Furthermore, 5GHz channels above channel number 100 cannot be used in some countries.

Q: Which SD cards are compatible with the AscTec Atomboard?

A: Please use 8GB SDHC (SanDisk works best) as boot medium. SD cards with more than 8GB are not supported.

To reinstall the standard Ubuntu image, please have a look here.

Q: Why does my LVDS display only show a white screen when booting up the Atomboard?

A: The LVDS display was most likely physically disconnected from or connected to the running Atomboard. Since it is not hot-pluggable, this damages either the Atomboard or the LVDS display. If it has happened, we would ask you to send us BOTH your Atomboard and your LVDS display for repair. It is usually hard to say, which of both was damaged and if it can be repaired or needs to be exchanged. Please contact "team@asctec.de".

Q: The AscTec Atomboard does not start - is it broken?

Symptoms: Display shows snow or nothing and system does not start.

A: Most likely not: The RTC/BIOS battery is empty. Thereby all BIOS settings (display, boot device,...) are lost.
Recovery:

  • Replace the battery (CR1025 3V)
  • Disconnect power supply
  • Connect LVDS display and keyboard
  • Connect power supply
  • Switch on the Atomboard
  • Press //Del// key immediately to enter BIOS setup utility and change following settings:
    • BIOS ? Load Optimized Defaults (confirm with //y//)
    • BIOS ? Advanced BIOS Features ? Second Boot Device ? Disabled
    • BIOS ? Advanced BIOS Features ? Third Boot Device ? Disabled
    • BIOS ? Advanced BIOS Features ? Customer Boot Logo ? Disabled
    • BIOS ? Advanced Chipset Features ? LCD Panel Type ? 03: 1024×768 S18
    • BIOS ? Integrated Peripherals ? Onboard Device ? USB Client Controller ? Enabled
    • BIOS ? Save & Exit Setup
  • Switch the Atomboard off and on again

AscTec Mastermind

Q: Are the serial ports broken?

Symptoms: UARTS send and receive garbage.

A: Quick Test: connect a serial x-over cable from UART_A (/dev/ttyS0) to a desktop PC with serial dongle; open a terminal program on the PC (11520 8N1); reboot the Mastermind; The Mastermind BIOS will print the message

on UART_A (/dev/ttyS0). If you see this message probably the UART clock is reconfigured for higher baud rates; This is mostly done by a bootloader (grub) script (e.g /etc/grub.d/09_config_serial).

Fix:

  • remove /etc/grub.d/09_config_serial (or similar)

  • update the bootloader update-grub
  • eventually reinstall the bootloader grub-install /dev/sda

Q: The arm compiler (or other 32-bit program) is not working

Symptoms: calling /usr/local/bin/arm7/arm-elf-gcc results in ... No such file or directory.

A: 32bit libraries are missing

Q: Where can I find the driver for the small LCD module?

A: There is a .deb package available for 64bit systems here. Please follow the below installation procedure:

Q: How do I contact the support?

A: Please write an email to support (at) asctec.de containing sufficient information to understand or reproduce your problem:

  1. System description:
    1. Purchase date / Customer number
    2. Flight system: Pelican / Firefly / Hummingbird / ResearchPilot / X3d / other robot
    3. Onboard computer: Atomboard / Mastermind CPU_1 / CPU_2 / CPU_3a (ci7-3517) CPU_3b (ci7-3612) / other ...
    4. Periphery: what other devices are connected to the onboard computer?
      WLAN (WPEA-110N / WEPWPEA-127N / Fritz! USB-N / ASUS 53N / intel /...),
      Cameras: IDS (bw/color) / MatrixVision (bw/color) / Pointgray / Flir / …
      Boot media: (SSD / SD-card/ CFast) type and manufacturer
    5. Operating System: AscTec Ubuntu 12.04-2 / own installation, Description of changes/setup
      kernel version (uname -a)
    6. Please attach output of uname -a, dmesg, lspci and lsusb
  2. Problem
    Please give a detailed description of what doesn’t work, and what you have tried so far.
    If possible send some minimal code to reproduce the problem.